re = /^((<PackageReference Include=".*" Version=).*)$\s+?^(?=.*^\2.*$)/m
str = '<PackageReference Include="CommandLineParser" Version="2.2.1" />
<PackageReference Include="CommandLineParser" Version="2.2.1" />
<PackageReference Include="CommandLineParser" Version="2.2.2" />
<PackageReference Include="Bob" Version="2.2.2" />
<PackageReference Include="Bob" Version="2.2.1" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end