using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((<PackageReference Include="".*"" Version=).*)$\s+?^(?=.*^\2.*$)";
string input = @"<PackageReference Include=""CommandLineParser"" Version=""2.2.1"" />
<PackageReference Include=""CommandLineParser"" Version=""2.2.1"" />
<PackageReference Include=""CommandLineParser"" Version=""2.2.2"" />
<PackageReference Include=""Bob"" Version=""2.2.2"" />
<PackageReference Include=""Bob"" Version=""2.2.1"" />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}