$re = '/^((<PackageReference Include=".*" Version=).*)$\s+?^(?=.*^\2.*$)/m';
$str = '<PackageReference Include="CommandLineParser" Version="2.2.1" />
<PackageReference Include="CommandLineParser" Version="2.2.1" />
<PackageReference Include="CommandLineParser" Version="2.2.2" />
<PackageReference Include="Bob" Version="2.2.2" />
<PackageReference Include="Bob" Version="2.2.1" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);