const regex = /^((<PackageReference Include=".*" Version=).*)$\s+?^(?=.*^\2.*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((<PackageReference Include=".*" Version=).*)$\\s+?^(?=.*^\\2.*$)', 'gm')
const str = `<PackageReference Include="CommandLineParser" Version="2.2.1" />
<PackageReference Include="CommandLineParser" Version="2.2.1" />
<PackageReference Include="CommandLineParser" Version="2.2.2" />
<PackageReference Include="Bob" Version="2.2.2" />
<PackageReference Include="Bob" Version="2.2.1" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}