import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((<PackageReference Include=\".*\" Version=).*)$\\s+?^(?=.*^\\2.*$)";
final String string = "<PackageReference Include=\"CommandLineParser\" Version=\"2.2.1\" />\n\n"
+ " <PackageReference Include=\"CommandLineParser\" Version=\"2.2.1\" />\n"
+ "<PackageReference Include=\"CommandLineParser\" Version=\"2.2.2\" />\n\n"
+ "<PackageReference Include=\"Bob\" Version=\"2.2.2\" />\n"
+ "<PackageReference Include=\"Bob\" Version=\"2.2.1\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}