using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-9]{1}(?:\d{7}|\d{5})-?\d{4}$";
string input = @"100000-0000
10000000-0000
190000000000
550000-0000
5500000000
1000000000
100000000000
11 цифр не попадают:
10000000000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}