use strict;
my $str = '100000-0000
10000000-0000
190000000000
550000-0000
5500000000
1000000000
100000000000
11 цифр не попадают:
10000000000';
my $regex = qr/^[1-9]{1}(?:\d{7}|\d{5})-?\d{4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}