$re = '/^[1-9]{1}(?:\d{7}|\d{5})-?\d{4}$/m';
$str = '100000-0000
10000000-0000
190000000000
550000-0000
5500000000
1000000000
100000000000
11 цифр не попадают:
10000000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);