import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9]{1}(?:\\d{7}|\\d{5})-?\\d{4}$";
final String string = "100000-0000\n"
+ "10000000-0000\n"
+ "190000000000\n\n"
+ "550000-0000\n"
+ "5500000000\n"
+ "1000000000\n"
+ "100000000000\n\n"
+ "11 цифр не попадают:\n"
+ "10000000000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}