// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9]{1}(?:\d{7}|\d{5})-?\d{4}$").unwrap();
let string = "100000-0000
10000000-0000
190000000000
550000-0000
5500000000
1000000000
100000000000
11 цифр не попадают:
10000000000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}