const regex = /^[1-9]{1}(?:\d{7}|\d{5})-?\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9]{1}(?:\\d{7}|\\d{5})-?\\d{4}$', 'gm')
const str = `100000-0000
10000000-0000
190000000000
550000-0000
5500000000
1000000000
100000000000
11 цифр не попадают:
10000000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}