#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)MY_KEY[^\S\r\n]*[\r\n]+[^\S\r\n]*\w+:[^\S\r\n]*'(\w+)'"
Local $sString = "Example 1:" & @CRLF & _
"" & @CRLF & _
"- key: MY_KEY " & @CRLF & _
" value: "{{ $MY_VAL }}"" & @CRLF & _
"Example 2:" & @CRLF & _
"" & @CRLF & _
"- key: MY_KEY " & @CRLF & _
" value: "$MY_VAL"" & @CRLF & _
"Example 3:" & @CRLF & _
"" & @CRLF & _
"- key: MY_KEY " & @CRLF & _
" value: '$MY_VAL'" & @CRLF & _
"Example 4:" & @CRLF & _
"" & @CRLF & _
"- key: MY_KEY " & @CRLF & _
" value: 'MY_VAL'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")