$re = '/MY_KEY[^\S\r\n]*[\r\n]+[^\S\r\n]*\w+:[^\S\r\n]*\'(\w+)\'/m';
$str = 'Example 1:
- key: MY_KEY
value: "{{ $MY_VAL }}"
Example 2:
- key: MY_KEY
value: "$MY_VAL"
Example 3:
- key: MY_KEY
value: \'$MY_VAL\'
Example 4:
- key: MY_KEY
value: \'MY_VAL\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);