using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"MY_KEY[^\S\r\n]*[\r\n]+[^\S\r\n]*\w+:[^\S\r\n]*'(\w+)'";
string input = @"Example 1:
- key: MY_KEY
value: ""{{ $MY_VAL }}""
Example 2:
- key: MY_KEY
value: ""$MY_VAL""
Example 3:
- key: MY_KEY
value: '$MY_VAL'
Example 4:
- key: MY_KEY
value: 'MY_VAL'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}