// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)MY_KEY[^\S\r\n]*[\r\n]+[^\S\r\n]*\w+:[^\S\r\n]*'(\w+)'").unwrap();
let string = "Example 1:
- key: MY_KEY
value: \"{{ $MY_VAL }}\"
Example 2:
- key: MY_KEY
value: \"$MY_VAL\"
Example 3:
- key: MY_KEY
value: '$MY_VAL'
Example 4:
- key: MY_KEY
value: 'MY_VAL'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}