re = /MY_KEY[^\S\r\n]*[\r\n]+[^\S\r\n]*\w+:[^\S\r\n]*'(\w+)'/m
str = 'Example 1:
- key: MY_KEY
value: "{{ $MY_VAL }}"
Example 2:
- key: MY_KEY
value: "$MY_VAL"
Example 3:
- key: MY_KEY
value: \'$MY_VAL\'
Example 4:
- key: MY_KEY
value: \'MY_VAL\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end