use strict;
my $str = 'Example 1:
- key: MY_KEY
value: "{{ $MY_VAL }}"
Example 2:
- key: MY_KEY
value: "$MY_VAL"
Example 3:
- key: MY_KEY
value: \'$MY_VAL\'
Example 4:
- key: MY_KEY
value: \'MY_VAL\'';
my $regex = qr/MY_KEY[^\S\r\n]*[\r\n]+[^\S\r\n]*\w+:[^\S\r\n]*'(\w+)'/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}