# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b([A-Z])|(\s)/\L\1_\2/g;t' <<< "Fuel surcharge"