using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([A-Z])|(\s)";
string substitution = @"\L\1_\2";
string input = @"Fuel surcharge";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}