import Foundation
let pattern = #"\b([A-Z])|(\s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Fuel surcharge"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\L\1_\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)