package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b([A-Z])|(\s)`)
var str = `Fuel surcharge`
var substitution = "\L\1_\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}