const regex = /\b([A-Z])|(\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([A-Z])|(\\s)', 'g')
const str = `Fuel surcharge`;
const subst = `\L\1_\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);