$re = '/\b([A-Z])|(\s)/';
$str = 'Fuel surcharge';
$subst = "\L\1_\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;