#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*Failed to install.*(exit code \d+)$"
Local $sString = "==BEGIN INSTALL SCRIPT==" & @CRLF & _
"Functional test suite mission impossible" & @CRLF & _
"[debug] - making dependencies" & @CRLF & _
"[info] - starting install 1/4" & @CRLF & _
"Other misc text 151 135137436 84 4 w6e" & @CRLF & _
"[info] - continue install 2/4" & @CRLF & _
"[error] - FAIL with erro 65" & @CRLF & _
"!!! Failed to install, with exit code 1603" & @CRLF & _
"Please verify your parameters" & @CRLF & _
"!!! Failed to install, with exit code 451" & @CRLF & _
"[FATAL] - Exiting now"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")