import re
regex = re.compile(r"^.*Failed to install.*(exit code \d+)$", flags=re.MULTILINE)
test_str = ("==BEGIN INSTALL SCRIPT==\n"
"Functional test suite mission impossible\n"
"[debug] - making dependencies\n"
"[info] - starting install 1/4\n"
"Other misc text 151 135137436 84 4 w6e\n"
"[info] - continue install 2/4\n"
"[error] - FAIL with erro 65\n"
"!!! Failed to install, with exit code 1603\n"
"Please verify your parameters\n"
"!!! Failed to install, with exit code 451\n"
"[FATAL] - Exiting now")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")