import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*Failed to install.*(exit code \\d+)$";
final String string = "==BEGIN INSTALL SCRIPT==\n"
+ "Functional test suite mission impossible\n"
+ "[debug] - making dependencies\n"
+ "[info] - starting install 1/4\n"
+ "Other misc text 151 135137436 84 4 w6e\n"
+ "[info] - continue install 2/4\n"
+ "[error] - FAIL with erro 65\n"
+ "!!! Failed to install, with exit code 1603\n"
+ "Please verify your parameters\n"
+ "!!! Failed to install, with exit code 451\n"
+ "[FATAL] - Exiting now";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}