using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*Failed to install.*(exit code \d+)$";
string input = @"==BEGIN INSTALL SCRIPT==
Functional test suite mission impossible
[debug] - making dependencies
[info] - starting install 1/4
Other misc text 151 135137436 84 4 w6e
[info] - continue install 2/4
[error] - FAIL with erro 65
!!! Failed to install, with exit code 1603
Please verify your parameters
!!! Failed to install, with exit code 451
[FATAL] - Exiting now";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}