// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*Failed to install.*(exit code \d+)$").unwrap();
let string = "==BEGIN INSTALL SCRIPT==
Functional test suite mission impossible
[debug] - making dependencies
[info] - starting install 1/4
Other misc text 151 135137436 84 4 w6e
[info] - continue install 2/4
[error] - FAIL with erro 65
!!! Failed to install, with exit code 1603
Please verify your parameters
!!! Failed to install, with exit code 451
[FATAL] - Exiting now";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}