$re = '/^.*Failed to install.*(exit code \d+)$/m';
$str = '==BEGIN INSTALL SCRIPT==
Functional test suite mission impossible
[debug] - making dependencies
[info] - starting install 1/4
Other misc text 151 135137436 84 4 w6e
[info] - continue install 2/4
[error] - FAIL with erro 65
!!! Failed to install, with exit code 1603
Please verify your parameters
!!! Failed to install, with exit code 451
[FATAL] - Exiting now';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);