#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*time)[^.]*$"
Local $sString = "testtime -> not allowed" & @CRLF & _
"tim etest -> allowed" & @CRLF & _
"." & @CRLF & _
"thetimetest -> not allowed" & @CRLF & _
"." & @CRLF & _
"the time test -> not allowed" & @CRLF & _
"test.my -> not allowed" & @CRLF & _
"my.testtime -> not allowed"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")