re = /^(?!.*time)[^.]*$/m
str = 'testtime -> not allowed
tim etest -> allowed
.
thetimetest -> not allowed
.
the time test -> not allowed
test.my -> not allowed
my.testtime -> not allowed'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end