const regex = /^(?!.*time)[^.]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*time)[^.]*$', 'gm')
const str = `testtime -> not allowed
tim etest -> allowed
.
thetimetest -> not allowed
.
the time test -> not allowed
test.my -> not allowed
my.testtime -> not allowed`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}