$re = '/^(?!.*time)[^.]*$/m';
$str = 'testtime -> not allowed
tim etest -> allowed
.
thetimetest -> not allowed
.
the time test -> not allowed
test.my -> not allowed
my.testtime -> not allowed';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);