import re
regex = re.compile(r"^(?!.*time)[^.]*$", flags=re.MULTILINE)
test_str = ("testtime -> not allowed\n"
"tim etest -> allowed\n"
".\n"
"thetimetest -> not allowed\n"
".\n"
"the time test -> not allowed\n"
"test.my -> not allowed\n"
"my.testtime -> not allowed")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")