# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!&|<)&/&/g;t' <<< "<a href=\"http://www.testassociation.com/test.html?ab=5&cd=5&ab=c\" target=\"_blank\">Customer Association</a>&"