using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!&|<)&";
string substitution = @"&";
string input = @"<a href=""http://www.testassociation.com/test.html?ab=5&cd=5&ab=c"" target=""_blank"">Customer Association</a>&";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}