re = /(?!&|<)&/
str = '<a href="http://www.testassociation.com/test.html?ab=5&cd=5&ab=c" target="_blank">Customer Association</a>&'
subst = '&'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result