const regex = /(?!&|<)&/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!&|<)&', 'g')
const str = `<a href="http://www.testassociation.com/test.html?ab=5&cd=5&ab=c" target="_blank">Customer Association</a>&`;
const subst = `&`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);