import Foundation
let pattern = #"(?!&|<)&"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<a href="http://www.testassociation.com/test.html?ab=5&cd=5&ab=c" target="_blank">Customer Association</a>&"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"&"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)