# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^CN=|(?<!\\),.+//gm;t' <<< "CN=manager-id,CN=Users,DC=ab,DC=cd"