$re = '/^CN=|(?<!\\\\),.+/m';
$str = 'CN=manager-id,CN=Users,DC=ab,DC=cd';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;