using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^CN=|(?<!\\),.+";
string substitution = @"";
string input = @"CN=manager-id,CN=Users,DC=ab,DC=cd";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}