re = /^CN=|(?<!\\),.+/m
str = 'CN=manager-id,CN=Users,DC=ab,DC=cd'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result