use strict;
my $str = 'CN=manager-id,CN=Users,DC=ab,DC=cd';
my $regex = qr/^CN=|(?<!\\),.+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";