const regex = new RegExp('^CN=|(?<!\\\\),.+', 'gm')
const str = `CN=manager-id,CN=Users,DC=ab,DC=cd`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);