# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?!(?:18|19|20)\d{2}\b)\d+\b//;t' <<< "I want to delete numbers like 84 but not dates like 2015"