$re = '/\b(?!(?:18|19|20)\d{2}\b)\d+\b/';
$str = 'I want to delete numbers like 84 but not dates like 2015';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;