import re
regex = re.compile(r"\b(?!(?:18|19|20)\d{2}\b)\d+\b")
test_str = "I want to delete numbers like 84 but not dates like 2015"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)