using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Need to process image tag.*\?custId=(\d+)";
string input = @"Need to process image tag <img src=\""http://danny.oz.au/p/56214815-tripod.jpg?custId=1235\""/>
Need to process image tag <img src=\""http://danny.oz.au/p/56214815-tripod.jpg?custId=123445\""/>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}