import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Need to process image tag.*\\?custId=(\\d+)";
final String string = "Need to process image tag <img src=\\\"http://danny.oz.au/p/56214815-tripod.jpg?custId=1235\\\"/>\n"
+ "Need to process image tag <img src=\\\"http://danny.oz.au/p/56214815-tripod.jpg?custId=123445\\\"/>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}